Редирект на страницу без .html. Как сделать?

Jasper Jasper  
2
  25.11.2016 19:42       811     Помощь  
Добрый день. Суть вопроса такова: Сменил движок сайта, в индексе на сторонних ресурсах есть ссылки на мои статьи. Пути оставил такими же но движок не дописывает .html как было раньше. Соответственно люди теперь попадают на 404

Как сделать редирект с мой.сайт/статья.html на мой.сайт/статья ?
Можно даже отдельно для каждой статьи их не много

Спасибо

Ответы на пост (13) Написать ответ
garik1331 garik1331
603
25.11.2016 19:48
Вы меня, а значит всех утомляете
С чего на что переехали то
0
garik1331 garik1331
603
25.11.2016 19:49
Хватит говно жевать
НАСТРОЕНИЕ У МЕНЯ СЕГОДНЯ СВОЕОБРАЗНОЕ
0
Jasper Jasper
2
25.11.2016 19:58
перешел с самописного (не моего) на image cms shop.
0
Jasper Jasper
2
25.11.2016 20:02
Как вариант может в .htaccess прописать эти редиректы? Я просто не совсем понимаю как)
0
PENSIONEER PENSIONEER
6
25.11.2016 20:44
Сам в этом не алё, но может для начала создать статичную страницу с адресом из ссылок, тогда она будет отображаться как .html?!
0
vituson vituson
2351
25.11.2016 20:45
https://yandex.ru/yandsearch?clid=2186618&text=%D1%83%D0%B1%D1%80%D0%B0%D1%82%D1%8C%20html%20%D0%B8%D0%B7%20%D1%81%D1%81%D1%8B%D0%BB%D0%BE%D0%BA%20htaccess&lr=11170
0
rovie rovie
0
25.11.2016 20:51
https://www.google.ru/search?rls=ru&q=301+редирект&gws_rd=ssl
0
Jasper Jasper
2
25.11.2016 20:55
Помогло вот такое решение
REWRITECOND %{HTTP_HOST} ^ваш_сайт.ру [NC]
REDIRECTMATCH 301 (.*)\.html$ http://ваш_сайт.ру$1
0
Jasper Jasper
2
25.11.2016 21:16
Хотя теперь другая проблема главную перенаправляет на /index и 404 выдает
0
Ninoi Ninoi
102
25.11.2016 23:21
htaccess покажи, никто не угадает, что там понаписано.
0
vipuslugi vipuslugi
17
26.11.2016 10:33
RewriteCond %{REQUEST_URI} !index.html$ [NC]
а если так добавить второй строкой?
0
Jasper Jasper
2
26.11.2016 15:36
Не помогает.
Мне помогло вот такое решение.
REWRITECOND %{HTTP_HOST} ^ваш_сайт.ру [NC]
REDIRECTMATCH 301 (.*)\.html$ http://ваш_сайт.ру$1
Но появились проблемы с главной страницей. Идет редирект главное на сайт/index
0
Jasper Jasper
2
26.11.2016 15:28
Вот мой .htaccess
AddDefaultCharset UTF-8

Options +FollowSymLinks
#Options -Indexes

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www.site.com.com$ [NC]
RewriteRule ^(.*)$ http://site.com/$1 [L,R=301]

#apache2ctl -M && sudo a2enmod expires && sudo service apache2 restart (to enable mod_expires on ubuntu)
<IfModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access 7 days"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType image/jpg "access plus 1 year"
ExpiresByType image/x-icon "access 1 year"
ExpiresByType application/x-shockwave-flash "access 1 year"
ExpiresByType application/javascript "access 1 year"
ExpiresByType application/x-javascript "access 1 year"
ExpiresByType text/css "access 1 year"
ExpiresByType text/html "access 1 year"
</IfModule>

RewriteRule ^(.*)\.tpl$ [R=404]
RewriteRule ^(.*)backups(.*)\.zip$ [R=404]

RewriteCond $1 !^(index\.php|user_guide|uploads/.*|favicon\.ico|docs|favicon\.png|captcha/.*|application/modules/.*/templates|application/modules/.*/assets/js|application/modules/.*/assets/css|application/modules/.*/assets/images|CHANGELOG.xml|templates|js|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* index.php [L]
0