Помогите с dle!!!

Vitaliy1996 Vitaliy1996   08.08.2013 20:37   624  

Суть проблемы
такова, поставил движок DLE
с кодировкой utf-8, но после
установки шаблона на сайте появилось вместо текста много непонятных знаков, такая,
же история с модулями и т.д. (шаблон и модуль тоже на utf-8). С шаблоном как-то
справился, но с модулем такая, же проблема. Может, кто имел такую проблему, и знает,
как с нею справится, может проблема в хостинге? Зарание благодарен. 


Ответы на вопрос (8) Написать ответ
CRYPO CRYPO   08.08.2013 20:42
в .htaccess добавь:
AddDefaultCharset windows-1251
<IfModule mod_charset.c>
CharsetRecodeMultipartForms Off
CharsetSourceEnc windows-1251
</IfModule>
0
Vitaliy1996 Vitaliy1996   08.08.2013 20:53

Не очень помогло (вообще), может что-то не так сделал?

0
BlackMaN333 BlackMaN333   08.08.2013 20:54
через Notepad перекодирую все в нужную кодировку(какая у двига)
0
CRYPO CRYPO   08.08.2013 21:01
делай то что сказал BlackMaN333, либо качай двиг с другой кодировкой (если не можешь ее так переделать).
0
Vitaliy1996 Vitaliy1996   08.08.2013 21:09

Но движок
кодировки utf-8, а в Notepad переделывал, но это не выход(

0
kpznanarah kpznanarah   08.08.2013 21:47
Переводить надо в UTF-8 без BOM! и притом надо копировать содержимое файла, создавать новый файл в UTF-8 без BOM и вставлять туда данные с 1251. и так все файлы шаблона.
0
mkrhst mkrhst   08.08.2013 22:21
поставь с кодировкой window-1251 и не мучайся
0
hldeadzone hldeadzone   25.07.2014 12:20
хостинг платный. не могу сделать каталог файлов с выпадающим меню,есть хуки какие нибудь чтоб можно было загружать так файлы на сайт и для загрузки пользователям?Или помогите сделать и склько это будет стоить?
0

Войдите, чтобы написать ответ
Вход Регистрация