Вопрос к знатокам wordpress

psyleads psyleads   10.02.2019 22:01   246  
привет Всем !
Есть проблема , нашел ее в новой google search консоли
При проверки любой внутренней страницы сайта https://obzoroff.info/ получаю
Uncaught ReferenceError: jQuery is not defined
Единственное что нашел на просторах гугла это код  в function.php

add_action( ‘wp_default_scripts’, function( $scripts ) {     if ( ! empty( $scripts->registered['jquery'] ) ) {         $scripts->registered['jquery']->deps = array_diff( $scripts->registered['jquery']->deps, array( ‘jquery-migrate’ ) );     } } );

Получаю теперь такое в сёрч консоли
jqmigrate: Migrate is installed, version 1.4.1
еще и Ресурсы страницы : 4 ресурса из 30 не удалось загрузить. В основном это изображения и скрипты гугл переводчика и гугл аналитики

Как вылечить это. Я так понял эти ошибки влияют на индексирование страницы и соответственно потом на результаты выдачи. На одном из моих сайтов уже по неделе и больше висят непроиндексированные страницы, хотя раньше за 5-10 минут влетали в поиск.

Ответы на вопрос (3) Написать ответ
sansan sansan   10.02.2019 22:19
Ну, как... Лечить "в соответсвии".
Я страницы пять назад задал тот же вопрос.
Без ответа.

Здесь вам никто не поможет, не тот уровень. Ну... попробуйте на хабре :) Там смешная ветка "про это".

Вопрос и простой, и сложный. Вы всё цитируете импортные консоли, а по-русски - пониаете их суть?
Там ведь... всё просто. Вам - перевести?

"Я вам тут туфты насыпал, жуйте жопой!" :)

Не, я понимаю "детский сад"... не обязательно верещать про то, что он - есть.
Вопрос - не к "знатокам", а к тем, что второй паз открыл WP. Второй! В третий - вопрос исчезнет.
0
psyleads psyleads   10.02.2019 22:26
Саныч, ты авторитетный человек, я уважаю твоё мнение. Таких как ты тут не более десятка. Но я облазил всё что мог, покурил буржуйские форумы. Туфты много, а по сути ничего не помогло. Реально не знаю куда дальше копать. Последние обновления wordpress сплошной геморрой: и совместимость плагинов страдает и требованиям гугла противоречат.
0
эта ошибка говорит о том что скрипт <script>jQuery.noConflict();</script>
подключен раньше(физически находится выше)
Чем подключен сам jQuery
поднять строку где подключается jQuery выше строки где подключается плагин

<script src="http://какойтоТамПлагин.ru/plugIn.js"></script>
<script src="http://Жквери.ru/Жквери.js"></script>

Так же на порядок подключения скриптов могут влиять атрибуты defer asunc
1

Войдите, чтобы написать ответ
Вход Регистрация


Вас банят при продвижении Адалт, Казино, Фарм? Для вас есть трастовые площадки под ВЕЧНЫЕ ССЫЛКИ!