Помогите с jquery для wordpress

Денис Потрехальчев Денис Потрехальчев   18.11.2016 01:17   631  
Дали инструкции, как их применить к wordpress 4.6.1 чтоб все работало
Распишите пожалуйста подробнее...
Вот инструкции

1. Подключаем плагин jQuery postMessage.
Требует jQuery старше версии 1.3.2

2. Вставляем в код страницы iframe.
Рабочая версия: http://taxsee.ru/orders3/frame.jsp
Версия для разработчиков: http://taxsee.ru/orders3-dev/frame.jsp
IFrame принимает GET параметры:
org - обязательный, идентификатор организации
base - идентификатор города выбранного по умолчанию
style - путь к css файлу, который будет встроен в код формы
lang - язык формы

3. Добавляем на страницу код:
var orderFrameHeight;
$(document).ready(function() {
$.receiveMessage(function(e){
var h = Number( e.data.replace( /.*orderFrameHeight=(\d+)(?:&|$)/, '$1' )
);
if ( !isNaN( h ) && h > 0 && h !== orderFrameHeight ) {
$('#frame-order').height( orderFrameHeight = h );
}
}, 'http://taxsee.ru' );
});
Заменить $('#frame-order') на селектор iframe-а.-------------------------

Что куда сувать? непонятно...

Ответы на вопрос (1) Написать ответ
hostifree hostifree   18.11.2016 05:50
По вашим ссылкам страницы с багами - вылезает окно вверху чтобы подтвердить действие - после подтверждения формы не работают. Следовательно вам надо искать другое решение:
postMessage
JSONP
CORS
document.domain methods
window.name Transport
Server-side proxy
CRAZY IFRAME STUFF
flash
0

Войдите, чтобы написать ответ
Вход Регистрация

Нужен профессиональный Логотип? Сделаем!